this problem seems to have appeared after a system upgrade ...

command line works fine

mysql -uschool -pbonfire school


/* Connecting, selecting database */
$link = mysql_connect("localhost", "school", "bonfire")
or die("Could not connect : " . mysql_error());
print "Connected successfully";
mysql_select_db("school") or die("Could not select database". mysql_error());


results in the following error

Connected successfully
Could not select database
Access denied for user: '@localhost' to database 'school'

the logfile shows this ...

030602 18:47:01 33 Connect [EMAIL PROTECTED] as anonymous on
33 Init DB Access denied for user: '@localhost' to database 'school'
33 Quit

Any ideas why the connection is being made as anonymous instead of with the details supplied ???

I'm running debian/testing which is up to date and all relavent systems are default install with some config changes...

I've tried re-building from scratch apache + php using the latest tarballs (installed to a different location) and still get the same error

I've also tried connecting to a different mysql server (same error) - in fact php still tries to connect to localhost !

I'll try installing a new version of mysql ... but any other ideas would be much appreciated



-- PHP Database Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to