On Monday 28 July 2003 16:38, Nabil wrote:

> I have been trying so hard to get that done.. and i posted many here. but
> with no hope.. here is a summury of what i did:
>
> - I tried FreeTDS as a driver with unixODBC ...
> - Tried to remove mysql- apache - php and recomplied them with : iodbc
> - Tried to try openlink driver.
> - tried to upgrade from redhat 7.3  to 9 as i faced do much problem with
> gcc compiler when i compiled php and apache..
>
> All the above with no hope ....
> so finaly , i formated the system then i installed a clean RedHat 9 with
> apache and php 4.2.2  and when i echo phpinfo() i got the following
>
> BUT WHAT IS dbx and there is Micrososft SQL server
>
> and when i call odbc_connect ...   i got Warning: SQL error:
> [unixODBC][Driver Manager]Data source name not found, and no default driver
> specified, SQL state IM002 in SQLConnect in /var/www/html/louai.php on line
> 11
> if my work was right .. how can i link the driver (FreeTDS and then the
> DSN..)

Have you configured

  /etc/odbc.ini
  /etc/odbcinst.ini

correctly?

-- 
Jason Wong -> Gremlins Associates -> www.gremlins.biz
Open Source Software Systems Integrators
* Web Design & Hosting * Internet & Intranet Applications Development *
------------------------------------------
Search the list archives before you post
http://marc.theaimsgroup.com/?l=php-db
------------------------------------------
/*
He who slings mud generally loses ground.
                -- Adlai Stevenson
*/


-- 
PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to