I'm having a problem using some php functions in LINUX machines.
I'm trying the "header" function  to redirect my visitiors to a specific page & i want to generate the pages dynamically ,
using arguments (For ex. redir.php?img=1.jpg). It is working fine in Windows machine , but not in LINUX/UNIX .
It is giving me error that headers are already sent .
I don't know why it is happening. I tried many things like
(1) I checked the configuration file (Php.ini) . some of the configurations r like that :
 arg_separator.input = "&"
 arg_separator.output = "&"
 output_buffering = off
(2) i tried changing the code . As i was found that the argument isn't coming from the previous page.
The code i used there is :
*********************************** redir.php *************************************************************
global $link;
header("Location: $link");
now if a link is like that : redir.php?link=http://www.yahoo.com  , then it should redirect the visitor to the YAHOO! ,
but it is working in Windows & not in LINUX.
In Windows , i saw this problem when the output_buffering is set to off. So i turned it on , & it is working fine in
windows, but in LINUX , the same problem persists. Using  "ob_start() " function , i tuned this function on (manually).
I don't know how to solve this problem.

I'm also unable to use MYSQL database in LINUX . It is saying that the built in PHP functions for
mysql (like mysql_connect() etc.) are unknown functions. Can anybody please help me ?????????

please help me .................
Thanking u
  IncrediMail - Email has finally evolved - Click Here

Reply via email to