I added mysql_error()  to get the error message.

I got the message that the user did not have rights on table

I figured that I must give some more global read rights to this user
(not just DB read rights). After that it worked.



-----Original Message-----
From: CPT John W. Holmes [mailto:[EMAIL PROTECTED] 
Sent: Friday, August 22, 2003 4:11 PM
To: Jack van Zanen Prive; [EMAIL PROTECTED]
Subject: Re: [PHP-DB] MYSQL 4.1 derived tables and PHP

From: "Jack van Zanen" <[EMAIL PROTECTED]>
> I have installed MYSQL 4.1 with support for derived tables. If I query
> with a query that has a subquery in the from clause it works fine. If 
> I
> load this query in PHP I get invalid resource error. If I change the
> for another select w/o the subquery it works fine (So my php script 
> must
> correct).
> Does PHP do syntax checking before sending the query to mysql? Any 
> other solution? I have tried PHP 4.3.2/4.3.3 & 5.0

What does mysql_error() say?

---John Holmes...

PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to