Daniel Watrous wrote:

In the above var_dump the [] actually appears as a small box and I cannot copy and paste it. The numerically indexed value (i.e. [0]=>string(4) "9542") is correct. The associatively indexed value (i.e. ["ORDER_ID"]=>string(4) "31[]3") is completely bogus. Has anyone else seen this behavior? Is there a fix for it? Any pointers would be appreciated...

I have tried adding a value MYSQL_ASSOC to the mysql_fetch_array and I have tried using mysql_fetch_assoc. Both return the same bogus value.

Maybe this is a character set problem? MySQL may be returning data in a certain character set that PHP is interpreting differently or doesn't understand (or your browser can't display it?).

Are you _sure_ nothing else is happening with the array or result set that could be doing this? Can you reduce it down to a couple lines of code and still reproduce this?


---John Holmes...

Amazon Wishlist: www.amazon.com/o/registry/3BEXC84AB3A5E/

php|architect: The Magazine for PHP Professionals – www.phparch.com

PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to