I've got a strange situation. I have followed all the
directions on how to compile FreeTDS and PHP 4.3.10 to
enable MSSQL support. Everything compiles fine works
from the command line, but the MSSQL functions fail
when I attempt to run them through the
Netscape/iPlanet/SunOne plug in.

I'm running RedHat 2.1AS on a dual processor Xenon
with 2G of ram. My webserver is SunOne(iPlanet)
version 6.1. I am also running version 4.0.1 of SunOne

Here's what I've done:

Built FreeTDS 0.62.4 with the following:
./configure --with-tdsver=8.0 --enable-msdblib
--enable-dbmfix --with-gnu-ld

It works and I can connect to my database with tsql.

I built PHP like this:
 ./configure  --with-nsapi=/opt/iplanet
--with-mysql=/usr --prefix=/usr/local --enable-fastcgi
--with-zlib --enable-dbase --enable-ftp --with-openssl

I am running the Zend_Optimizer2.5.7 and IonCube
extensions. I can see that MSSQL support is compiled
in from phpinfo

If I run this from the command line:
php -r '$con= mssql_connect("<mydb>","<uid>","<pwd>");
$rs=mssql_query("SELECT * from <tablename>",$con);
print mssql_result($rs,0,0);

I get the output I expect.

If I run this through the webserver:
$con= mssql_connect("<mydb>","<uid>","<pwd>");
$rs=mssql_query("SELECT * from <tablename>",$con);
print mssql_result($rs,0,0);

The only output I receive is "<html><body>"
No error logs are generated anywhere (webserver, php,
or freetds), even though php and freetds logging is
enabled. Other php scripts that dont use the mssql
functions run fine.

It seems to fail at the first mssql_ function and no
processing continues after that.

If anyone has an idea or a way to verify if the
ext/mssql module is compiled into the libphp4.so
object, I would apprecate it.


Do you Yahoo!? 
Yahoo! Mail - 250MB free storage. Do more. Manage

Do you Yahoo!? 
Send a seasonal email greeting and help others. Do good. 

PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to