You have mysql 4.1.8, but your php was built with the library for an earlier version, which, as the error message says, doesn't support the new, more secure authentication protocol. Your choices are to tell mysql to use the older, less-secure protocol, or build a copy of php using your current mysql client library. See the manual for more <http://dev.mysql.com/doc/mysql/en/old-client.html>.


Michael

GH wrote:

I just installed phpMyAdmin 2.6.1 on my Windows Laptop with PHP
Version 4.3.10  [Build Date  Dec 14 2004 17:46:48] and mySql 4.1.8

I am receiving the enclosed error  when I attempt to go into
phpMyAdmin and do not know how to solve the issue...

Any assistance would be greatful.

Thank you
Gary


//############## ERROR RECIEVED ####################//

Welcome to phpMyAdmin 2.6.1

phpMyAdmin tried to connect to the MySQL server, and the server
rejected the connection. You should check the host, username and
password in config.inc.php and make sure that they correspond to the
information given by the administrator of the MySQL server.

Error MySQL said:

#1251 - Client does not support authentication protocol requested by server


-- PHP Database Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php



Reply via email to