I am using php 5.0.4 on SuSE 9.3 with Apache 2.0.54 and Oracle
10.1.0.3. I configured and built php with this:
./configure --prefix=/usr/local/php-5.0.4
--with-apxs2=/usr/local/apache2/bin/apxs --enable-cli --enable-cgi
--enable-short-tags --enable-calendar --enable-dba --enable-dio
--enable-ftp --with-gd --with-gettext --with-mysql
--with-mysql-sock=/var/lib/mysql/mysql.sock
--with-oci8=/u01/app/oracle/product/10.1.0.3  --enable-sockets
--with-zlib-dir

When I execute phpinfo() it shows the OCI8 support is enabled.

However, ora_logon, Ora_Login, OCILogOn all fail with the same error.
I then saw a section in the documentation that says if you receive
this error, configure with these two options:

--with-oracle=DIR
--with-oci8=DIR

However, when I add the --with-oracle directive it fails:
checking for Oracle-ORACLE support... yes
checking Oracle Install-Dir... /u01/app/oracle/product/10.1.0.3
checking Oracle version... configure: error: Oracle needed libraries not found

Anyone have any ideas?
Thx,
CC

--
PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to