The error I'm getting is from the PHP function. Both mssql_connect and
PEAR are returning the same error.  As far as I can tell, mssql only
returns the last line of an error message so I can't be sure that the
error I'm seeing is from MSSQL or PHP.  Running TCPdump shows no
traffic is going to my sql database from the webserver.  But when I run
tsql,it shows that communication occurred. 

This looks like a problem with my PHP configuration but I'm at a loss as
to what it is.


Micah Stevens <[EMAIL PROTECTED]> wrote on 11/01/2005, 11:55:52
> Is it from php or the mssql driver? If it's from the driver, then the library 
> is installed at least partially correctly. If it's from php, perhaps not. 
> From there you can narrow it down by checking the connection parameters 
> outside of php to make sure they're right, is there a mssql client for linux?
> If the driver is loading, I would hope it would give better error messages 
> than just 'connection failed'.. but as I've never used the driver I might be 
> wrong. 
> You can also packet sniff the network during the connection attempt to see 
> what goes on there, there's lots of clues that could be helpful in the packet 
> stream. 
> -Micah 
> On Tuesday 01 November 2005 2:30 pm, [EMAIL PROTECTED] wrote:
> > A few months back I wrote the list asking for help making a connection
> > to a MS SQL database from our linux webserver.  At that time I was able
> > to make a successfull connection on Fedora Core 1 after installing
> > php-mssql.rpm and a freetds rpm.  When I upgradd to FC4, I was unable
> > to continue my project because the RPMs had not been built for
> > PHP5.0.4, whic is the version we run now.
> >
> > Today, I was able to get the version of php-mssql I needed and installed
> > it successfully.  I am able to make a connection to our ms sql server
> > using tsql.  There is a mssql.ini file in the php.d directory and the
> > file is in /usr/lib/php/modules/.  Using the
> > get_loaded_extensions fuction, I see that mssql is a loaded module and
> > the phpinfo() function shows me mssql configuration files.  All
> > indicators tell me that I should be able to connect.
> >
> > Obvsiously, since I'm posting to the list, you can guess that it's not
> > working.  The error message I get back is useless as I'm only told that
> > the connection failed.  Does anyone know anything else I need to check
> > to get the connection working?
> >
> > Thank you,
> > Robbert van Andel
> --
> PHP Database Mailing List (
> To unsubscribe, visit:

PHP Database Mailing List (
To unsubscribe, visit:

Reply via email to