This isn't really a MySQL error (sorta), it's a PHP error.  You probably forgot 
to update a variable name when you updated everything else.

Here's an example sequence for querying using PHP/MySQL:

$TestQY = "SELECT * from SomeTable";
$TestRS = mysql_query($TestQY) or die("Error executing query");
while ($TestRW = mysql_fetch_assoc($TestRS)) {
  $somearr[] = $TestRW;  // do something with data

Since you're getting a "Not a valid MySQL result resouce" error with the 
mysql_fetch_assoc() function, I'd search for all your mysql_fetch_assoc() 
statements and double check their $TestRS.  That error is saying that your 
$TestRS isn't a valid MySQL result set.  That could mean that $TestRS isn't 
defined (maybe you're still using $TestOldRS and forgot to change a variable 
name) or possibly that $TestQY is empty or bad somehow so mysql_query() isn't 
generating a proper MySQL result set (try echoing out your $TestQY to see what 
it is.. then try executing it manually on the MySQL server and see if you get 
an error).

You can try the "or die()" syntax I use above to see if mysql_query() is 
bombing out so you'll get notice before it even gets to the mysql_fetch_assoc().

Lastly.. someone recommended echoing out mysql_error(). Your response makes it 
sound like you think that this fixes your problem.  It's not going to fix 
anything, just possibly give you some information about what failed.  If you 
get a MySQL error message from mysql_error(), please post it. It might help us 
determine what the problem is.

It may not contain anything (under certain failing circumstances) so I'd step 
through the things I've listed above.  They may shed some light on where the 
error is and then we can figure out how to fix it.   Probably a typo in a 
query, variable name or table name I'm guessing.

Let us know if you find anything else out.


= = = Original message = = =

After adding echo mysql_error(); I get the same result.  I tried changing  
the query to include 109fh7 (a table which doesn't exist) and got the same  
result as with 109fh6.  Changing to 109fh5 does pull up that table.  The  
line to which the error message refers is while ($row = mysql_fetch_assoc  
($data_set))  That is what always come up when there is an error in the  

On Mon, 12 Dec 2005 14:13:10 -0500, Micah Stevens  

> You're getting an error, after the query, put:
> echo mysql_error();
> to find out what's happening.
> On Monday 12 December 2005 11:05 am, [EMAIL PROTECTED] wrote:
>> I made tiny changes to my php file and sql table and the table won't  
>> come
>> up.  I updated the table name (and php file name) from 109fh5 to 109fh6.
>> In the table, I changed 6 cells, leaving a couple blank.  Then I changed
>> only the digit "5" to make it a "6" (109fh6) in the following:
>> $get_data_query = "select rep, party, state, cd, minority, afr_am,  
>> asian,
>> am_indian, hispanic, med_hsehold_income, poverty from 109fh6 order by
>> $sort_field $sort_order";
>> Now I get "Warning: mysql_fetch_assoc(): supplied argument is not a  
>> valid
>> MySQL result resource in" etc.
>> I've done this many times without a problem (this is the 6th time in  
>> this
>> sequence).  What could be wrong after such a minor change?
>> Ken

Sent by ePrompter, the premier email notification software.
Free download at

PHP Database Mailing List (
To unsubscribe, visit:

Reply via email to