I have tried adding the following line to my php page. This causes the
php page to fail.


I have tried adding

$oci=oci_pconnect($user, $pass, $db,'WE8ISO8859P1');

I don't believe the error is due to character sets. I believe it is a
problem with binding parameter to oracle procedures in php.
If I remove the binding the procedure works. If I add it it fails.

Any ideas


-----Original Message-----
From: Roberto Mansfield [mailto:[EMAIL PROTECTED]
Sent: 26 June 2007 16:09
To: php-db@lists.php.net
Subject: [PHP-DB] Re: Error

This could be a problem with your ORACLE_HOME and/or NLS_LANG
environment variables. These need to be set for your user account
running the web server BEFORE the web server is started. Don't try to
set these in your php script or you'll get strange results.

David Skyers wrote:
> Hi
> I have a page that inserts data into a oracle table using a oracle
> stored procedure via php. However when the php runs I get the
> following
> error:
> Warning: oci_execute() [function.oci-execute]: ORA-06550: line 2,
> column
> 7: PLS-00553: character set name is not recognized ORA-06550: line 0,
> column 0: PL/SQL: Compilation unit analysis terminated in
> /nfs/rcs/www/webdocs/research/rsr/staff/dev/rae-mypubs1.php on line
> 121
> Does anyone know why this is occurring?
> Regards
> David

PHP Database Mailing List (http://www.php.net/) To unsubscribe, visit:

Reply via email to