On May 1, 2008, at 7:56 AM, Jason Pruim wrote:

On Apr 30, 2008, at 5:03 PM, Philip Thompson wrote:

On Apr 30, 2008, at 10:54 AM, Jason Pruim wrote:
Hi Yves,

Thanks for the tip, that worked, I think I'll use that from now on..

Just out of curiosity though, any idea why it wasn't working as I was writing it :)

Did you try putting the query that PHP is generating in phpMyAdmin or MySQL Query Browser? See if it throws an error when attempting to update. It *appears* that the query should work.

No I haven't, I don't have phpMyAdmin installed since I do it all from the command line, and I don't pay for hosting yet... But I am going to need to change that. I don't believe I have heard about MySQL Query Browser though... Is it a webapp? Or do I need to install it on my local computer?

Query Browser is part of the MySQL GUI tools. You can download them here and use on your local computer:


However, if you're using command line, then that should provide the same error messages (if any) that may assist you.


PS... Was it you, Jason, or someone else who asked about the security of the community knowing their database structure and I encouraged the use of `backticks` around all field and table names?

Yeah it was me... Old habits die hard :) I'm working on converting everything :)

On Apr 30, 2008, at 11:47 AM, YVES SUCAET wrote:

Hi Jason,

It's not because you create a date/time value that you automatically have an integer-value. You need to specify first that you want the date/ time value
converted to an integer value first.

for an example of how to do this.

Actually, by using this function, you probably don't even need to create the $modifiedTimestamp variable anymore. You can just write your SQL query as

$sql = "Update `mytable` set timestamp=UNIX_TIMESTAMP() where Record='1'";



------ Original Message ------
Received: Wed, 30 Apr 2008 10:39:11 AM CDT
From: Jason Pruim <[EMAIL PROTECTED]>
To: Stut <[EMAIL PROTECTED]>Cc: php-db@lists.php.net
Subject: Re: [PHP-DB] Timestamps

On Apr 30, 2008, at 11:35 AM, Stut wrote:

On 30 Apr 2008, at 16:29, Jason Pruim wrote:
Okay... So I know this should be simple...

Trying to store a timestamp in a MySQL database... The timestamp I
am making like so: $modifiedTimestamp = time();

and then just $sql = "Update `mytable` set
timestamp='$modifiedTimestamp' where Record='1'";

Simple right? Not quite...in my database it's storing a "0" in the
timestamp field which is a int(10) field.

I have googled, and searched manuals, but have not been able to
figure out what is going on....

Any Ideas?

timestamp is a reserved word. Try putting it in backticks.

Okay, so I did a really crappy job at my sudo code... The field name
is actually Last_Updated.

so my update code looks like this: Last_Updated='$modifiedTimestamp'

*Slaps his wrist... Bad copy/paste! BAD!!!

PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to