Hi Chris,

Thanks for your response.

Do you mean i am using 32bit PHP libraries? If so could you please let me know 
where to download 64bit PHP libraries. I tried over the net but i couldn't get 


--- On Thu, 3/5/09, Chris <dmag...@gmail.com> wrote:
From: Chris <dmag...@gmail.com>
Subject: Re: [PHP-DB] Need help in solving issues with configuration of  
php-5.2.8 with mysql-5.3.1
To: niranjan_...@yahoo.com
Cc: php-db@lists.php.net
Date: Thursday, March 5, 2009, 3:01 AM

niranjan k wrote:
> Hi Chris,
> Thanks for the response.
>> 1. I ran php configuration as below.
>> $./configure --with-apxs2=/usr/local/apache2/bin/apxs
>> --with-mysql=/apps/mysql/mysql
>> It went fine.
> Chris > Are you sure? 
> Yes it went fine.
>> 2. While running make, i got following relink error.
>> ld: fatal: file /usr/local/mysql/lib/libmysqlclient.so: wrong ELF
> Chris > Look at the path of the file it picked up - it found one in a
> completely different location.
> The path it has taken /usr/local/mysql/...
> There is a soft link to /usr/local/mysql which points to /apps/mysql/mysql

and we're supposed to guess that? ;)

I guess you can't build 64 bit binaries with 32 bit libraries. The
php-install list may have better suggestions but as far as I know you either
have to use 64 bit (including libraries) or 32 bit - you can't mix &

-- Postgresql & php tutorials


Reply via email to