--- On Thu, 8/13/09, Fred Silsbee <fredsils...@yahoo.com> wrote:

> From: Fred Silsbee <fredsils...@yahoo.com>
> Subject: Re: [PHP-DB] Fedora 9-->10 ..now "oracle connect error"
> To: "Christopher Jones" <christopher.jo...@oracle.com>
> Date: Thursday, August 13, 2009, 11:36 PM
> after working for nearly 9 months, 
> 
> "oracle connect error"
> 
> LMKIII (root) ~ [999]>lsa /etc|grep -i php
> drwxr-xr-x   2 root     root       4096
> 2009-08-13 04:46 php.d/
> -rw-r--r--   1 root     root      45812
> 2009-08-13 12:32 php.ini
> -rw-r--r--   1 root     root      45804
> 2009-04-17 02:44 php.ini.rpmnew
> -rw-r--r--   1 root     root      45533
> 2009-08-13 03:54 phpini.save
> 
> copied php.ini.rpmnew to php.ini
> 
> made changes (new php.ini attached)
> 
> 
> > > Oracle Connect Error 
> > 
> > What error?  What Oracle client libraries do you
> > have?  Where
> > are they located
> > 
> LMKIII (root) ~ [1000]>locate oci8.so
> /home/oracle/oci8/oci8-1.3..4/.libs/oci8.so
> /home/oracle/oci8/oci8-1.3.4/modules/oci8.so
> /home/oracle/oci8/oci8-1.3.5/.libs/oci8.so
> /home/oracle/oci8/oci8-1.3.5/modules/oci8.so
> /usr/lib/php/modules/oci8.so
> 
> > > just upgraded Fedora 9->10
> > > 
> > > using new php.ini file containing:
> > > 
> > > ;;;;
> > > ; Note: packaged extension modules are now loaded
> via
> > the .ini files
> > > ; found in the directory /etc/php.d; these are
> loaded
> > by default.
> > > ;;;;
> > > 
> > > I entered a file oracle.ini into /etc/php.d
> containing:
>  
> ; Enable mysql extension module
> extension=oci8.so         
> >      this line exists also in php.ini
> > > 
> > > ..so files are where they ought to be
> > 
> > Which is where?
> > 
> > What is extension_dir set to?
> ; Directory in which the loadable extensions (modules)
> reside.
> extension_dir = "/usr/lib/php/modules"
> ;extension_dir = "/home/oracle/oci8/oci8-1.3.4/modules"
> 
> > 
> > What is LD_LIBRARY_PATH set it in the "Environment"
> (not
> > the "Apache
> > Environment") of phpinfo() output?
> LMKIII (root) /etc [1001]>echo $PATH
> /usr/lib/qt4/bin:/usr/lib/qt4:/usr/lib:/usr/lib/qt-3.3/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/lib/ccache:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin:.
> 
> in /etc/httpd/conf/httpd.conf
> 
> SetEnv ORACLE_HOSTNAME localhost.localdomain
> SetEnv TNS_ADMIN
> /u01/app/oracle/product/11.1.0/db_1/network/admin
> SetEnv ORACLE_BASE /u01/app/oracle
> SetEnv ORACLE_HOME /u01/app/oracle/product/11.1.0/db_1
> SetEnv ORACLE_SID lmkiiiGDNSID
> SetEnv ORACLE_TERM xterm
> SetEnv LD_LIBRARY_PATH /u01/app/oracle/product/11.1.0/db_1/lib
> 
> 
> > 
> > > 
> > > mysql works with php as before update
> > > 
> > > 
> > > 
> > > 
> > > 
> > > 
> > >       
> > > 
> > 
> > -- Blog: http://blogs.oracle.com/opal
> > Twitter:  http://twitter.com/ghrd
> >
> 
> 
>       





--
PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to