I ran into a rather strange problem with ldap_connect().
When I take the ldap example in the php manual and run
it with a php cgi version it works without problems. If I
take apache with php compiled in, the ldap_connect() call
always returns false. I tried two different ldap servers
which are known to work. In both cases ldap_connect() fails.
The system I use is linux 2.2.14 (Intel) and apache 1.3.14.
Do the same on Linux PPC works.

Next thing I did, was modifying ext/ldap/ldap.c in order to
print errno right after ldap_open(). The error number is in
any case 25 which doesn't help me at all.

Then I fired up gdb, set a breakpoint right before ldap_open()
in php_if_ldap_connect() and run httpd with -X -f <conf.file>.
Steping into ldap_open() didn't work, though openldap was compiled
with --enable-debug. BTW, listing the openldap file in which
ldap_open() is defined works. Setting a breakpoint in ldap_open()
didn't have any effect which supports my theory that ldap_open()
isn't called for some mystical reason.

Another strange think is, that apache compiled ok even without giving
-lldap -llber -L<path to openldap>/lib. ldd ./httpd doesn't list
the ldap shared library. Doint 'nm httpd|grep ldap' list a number of
undefined symbols which are defined in libldap. How can that be?

I have seen similar problems on one of the php mailing list, but
no answer :-(

Could somebody please help.
This drives me crazy.


  Tel: +2331 987 4528    Fax: +2331 987 375

PHP Development Mailing List <http://www.php.net/>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to