ID: 8751
User Update by: [EMAIL PROTECTED]
Old-Status: Open
Status: Closed
Bug Type: PHP options/info functions
Description: configure misdetects zlib on FreeBSD 4.1.1

I ran configure with those same flags again in order to gather some more information 
for you guys, and strangely enough it worked this time. I did a 'make clean' and 'rm 
config.cache' before running configure this time, so there must have been some bad 
information in the cache that caused it to fail on zlib those other times.

Previous Comments:

[2001-01-17 02:01:49] [EMAIL PROTECTED]
When running configure for PHP 4.0.4pl1 on FreeBSD 4.1.1/i386, configure fails to 
properly detect FreeBSD's builtin zlib support. Zlib version 1.1.3 is preinstalled in 
/usr/lib/libz.{a,so}, however when configure tries to verify zlib's presence it says 
"zlib support requires zlib version >= 1.0.9" and terminates. It also complains that 
it can't find gzgets in -lz.

The exact command line I used was:
./configure --with-apxs --enable-sigchild 
--enable-magic-quotes --enable-bcmath --with-bz2 
--with-gdbm --with-ndbm --enable-ftp --with-gd=/usr/local 
--with-jpeg-dir=/usr/local --with-xpm-dir=/usr/X11R6 
--with-ttf --enable-gd-imgstrttf --with-imap 
--with-java=/usr/local/jdk1.1.8 --with-ldap --with-mhash 
--with-mysql=/usr/local --with-iodbc --with-pdflib 
--with-zlib-dir=/usr --with-png-dir=/usr/local 
--with-tiff-dir=/usr/local --with-mm --enable-trans-sid 
--with-zlib=/usr --enable-sockets 
--enable-inline-optimization --enable-memory-limit

Upon removing the --with-zlib flag, php compiles fine and works normally.


Full Bug description available at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to