From:             [EMAIL PROTECTED]
Operating system: Redhat Linux 7.0 (fully updated)
PHP version:      4.0.4pl1
PHP Bug Type:     Filesystem function related
Bug description:  fopen("","r") hangs my script

The problem is that when I open a web-page with the fopen("url","r") function, my 
scirpt hangs for no preticiular reason. It occurs both if I run 'php myscript.php' and 
if I use it on a web-page.

A script that reproduses the problem could be found at

I Run the PHP RPM package that's supplied by RedHat. It's fully updated to the latest 
I havn't changed anything in my php.ini, so I guess it looks in the way RedHat has 
made it. I can send it to anyone who'd like to see it.

I run apache 1.3.14-3 (RPM installed).
The machine is a P166 with 96MB of ram. As I said, it runs RedHat 7.0 with all 
updates. the 2.2.16-22 kernel is used. 

If you'd like to know something else about the env. just let me know!

Edit Bug report at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to