ID: 6491
Updated by: cynic
Old-Status: Closed
Status: Open
Bug Type: Scripting Engine problem
Assigned To: 

user feedback:

Apologies for the delay, but NO, you should NOT close this problem yet.
It still occurs in PHP v4.0.3pl1 & v4.0.4pl1.

Previous Comments:

[2001-02-20 08:01:32] [EMAIL PROTECTED]
No feedback.



[2001-01-12 06:06:31] [EMAIL PROTECTED]
could you try if this happens with newer versions of PHP? (4.0.4pl1 is out)


[2000-09-04 17:11:47] [EMAIL PROTECTED]
Note, in the Microsoft Management Console (MMC) I have configured IIS to map .php 
files to php.exe in the App Mappings section as explained in the PHP readme file.

I have not tried changing the extension mapping to something else (e.g., change the 
mapping to ".php3" and see whether directories ending with ".php3" suddenly cause the 
same problem).  Will try that some time when time permits.  For now, I simply avoid 
directory names ending in ".php" until this bug is addressed.


[2000-09-01 15:28:31] [EMAIL PROTECTED]
Place the following simple file (called version.php for this example):

in your website such that it is contained somewhere within the subtree of a directory 
whose name ends with ".php".  For example, on my box I had the file located at


If you then look at the value of $PHP_SELF it is


and NOT


as it should be.

I've tried using other directory names such as "secure.ppp", "secure.txt", and 
"secure.html" and those seem to work fine.  It only occurs when a directory name ends 
with ".php".  Possibly a bad regular expression used to parse the path?


ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to