From:             [EMAIL PROTECTED]
Operating system: linux redhat6.2
PHP version:      4.0.4pl1
PHP Bug Type:     *Install and Config
Bug description:  removing config.cache but still getting same install as before

i compiled php with gd and all was well.
a few days later on i upgraded gd and restarted apache,
Starting httpd: Syntax error on line 250 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/apache/ into server: /usr/lib/ undefined 
symbol: png_set_dither

make output: could not find libgd.(a|so) anywhere in /usr/lib (although its there for 

to get php up and running again without any loss of time i decided to do a recompile 
without gd.
so i recompiled php: 
rm config.cache
./configure --with-apxs
make install

but apache still gives the same error when starting although gd isnt even compiled 
into php this time!!

this made me think.
so i decided to to try a few different versions of gd and kept getting exactly the 
same apache error everytime although gd was working fine for webalizer..

delete the whole source dir.
untar src again and compile again.

now it works.

so removing the config.cache doesnt give you a clean install at all, it seems to 
repeat the first install exactly everytime, although the INSTALL file says that 
removing the config.cache file should get you a fresh install.

maybe this isnt a bug but a feature, but i dont seem to remember php did this in 
previous versions....?

Edit Bug report at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to