From:             [EMAIL PROTECTED]
Operating system: Windows 2000
PHP version:      4.0.4pl1
PHP Bug Type:     Dynamic loading
Bug description:  Dynamic libraries are not being found in the php.ini's extension_dir

Everytime I try to load any dynamic library from the php.ini's extension_dir, I get 
the following error (the dll specified changes depending on what library I am trying 
to load):

Unable to load dynamic library 'C:\Inetpub\php\extensions/php_gtk.dll' - The specified 
procedure could not be found.

My php.ini file contains the following line:

extension_dir = C:\Inetpub\php\extensions

It occured to me that I was missing a trailing backslash; therefore I changed my ini 
file to:

extension_dir = C:\Inetpub\php\extensions\

This didn't seem to help as I got a similar error message:

Unable to load dynamic library 'C:\Inetpub\php\extensions\php_gtk.dll' - The specified 
procedure could not be found.

I then thought that maybe any dll I load from the extension dir must also be in the 
%systemroot%\system32 dir, so I copied the php_gtk.dll to C:\WINNT\system32.  Sadly, I 
kept getting the same error.

I also tried putting single qoutes and double qoutes around the extension_dir path... 
as you can guess, I got the same error.

This seems to me, to be a very serious problem!  I can't understand how the inability 
to load dynamic libraries has gone unnoticed for so many versions.

Any help on this matter would be greatly appreciated!

I am running php 4.0.4pl1 as a CGI on Windows 2000 / IIS.

As a side not, I have compiled and configured php many times, on various Linux 
installations, and dynamic loading works perfectly.

Edit Bug report at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to