ID: 9726
User Update by: [EMAIL PROTECTED]
Old-Status: Feedback
Status: Open
Bug Type: Apache related
Description: the HTTP_POST_VARS are prepended by RC BS

Recompiling php4 (with the right httpd.h) solved the problem.
Before, both apache and php were installed by way of RPMs:
apache-1.3.14-3 and php-4.0.4pl1-3

It seems that these RPM were not fully compatible (they were not compiled together).

Previous Comments:

[2001-03-13 22:21:32] [EMAIL PROTECTED]
Please try the latest CVS snapshot from as I can't reproduce 



[2001-03-13 10:01:05] [EMAIL PROTECTED]
The script below worked with php3. When the button
<input type="submit" name="Enregistrer" value="Enregistrer" >
is clicked, the variable $Enregistrer gets the value "Enregistrer" and the test
says yes.

We transfered our site on a server with PHP4 and then the HTTP_POST_VARS are prepended 
by two characters RC BS (decimal codes 13  & 10) and the above test says no.
If I change the test to
it says yes.
<head> <SCRIPT LANGUAGE="JavaScript" src="script.js"> </SCRIPT> </head>
<form method=POST enctype="multipart/form-data"
        action="<? echo $PHP_SELF ?>" name="formu">
echo "$xxx:$yyy:$Enregistrer:<br> ";
echo "-$xxx-$yyy-$Enregistrer[2]-$Enregistrer[11]-$Enregistrer[12]-<br>";
echo "$xxx:$yyy:$Fonction:<br>";
echo "-$xxx-$yyy-$Fonction[2]-$Fonction[21]-$Fonction[22]-<br>";
/* if(strcmp(substr($Enregistrer,2),"Enregistrer")==0) */
  { echo "enregistrer"; }
  { echo "ne pas enregistrer"; }
<?php PRINT "<select name="Fonction">";
      PRINT "<option selected value="$Fonction">$Fonction";
      PRINT "<option value = "Professeur"> Professeur</option>";
      PRINT "<option value = "Maître"> Maître</option>";
      PRINT "</select>";
<p> <input type="submit" name="Enregistrer" value="Enregistrer" > </p>
</form> </body> </html>
Configure Command 
                              './configure' '--prefix=/usr'
                              '--with-config-file-path=/etc' '--disable-debug'
                              '--enable-pic' '--enable-shared'
                              '--with-apxs=/usr/sbin/apxs' '--with-exec-dir=/usr/bin'
                              '--with-regex=system' '--with-gettext' '--with-gd'
                              '--with-jpeg-dir=/usr' '--with-png' '--with-zlib'
                              '--with-db2' '--with-db3' '--with-gdbm'
                              '--enable-debugger' '--enable-magic-quotes'
                              '--enable-safe-mode' '--enable-sockets'
                              '--enable-sysvsem' '--enable-sysvshm'
                              '--enable-track-vars' '--enable-yp' '--enable-ftp'
                              '--enable-wddx' '--without-mysql' '--without-oracle'
                              '--without-oci8' '--with-xml'
other parts of phpinfo()

register_globals    On 
Apache Version      Apache/1.3.14
Apache Release      10314100
Apache API Version  9990320


Full Bug description available at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to