Hi Adam,

> the good thing is that the binary works! I am, however, still
> unable to produce a binary myself that doesn' crash.
> I've tried to upgrade to glibc 2.1.2 from 2.1.1. I've also tried
> to recompile the whole thing on a Redhat 7.1 beta (Fisher) with kernel
> 2.4.2-ac3 and glibc 2.2.1-3 installed and the PHP CVS snapshot from today.

    Wow, you are putting quite a lot of energy into this :-)

> Perhaps I'm not compiling the stuff correctly. I used
> the MANUAL method as described in the readme from the ircg
> extension: - 1=install st, 2=instal IRCG, 3=unpack thttpd,
> 4=php install, 5=patch thttpd, 6=compile,install thttpd.

    Looks allright.  If thttpd starts up, it is very unlikely
    that you did something wrong during building it.

> On the Redhat 7.1 beta the GDB trace is somewhat more informative:
> #0  0x080ec730 in irc_cmd_RPL_NAMREPLY (conn=0x8186650, msg=0x4001a8f4)
>     at irc_dispatcher.c:189
> 189           ep = irc_locate_channel(conn, msg->para[2].c);
> (gdb) print *msg
> $2 = {cmd = {c = 0x4001aa13 "353", len = 3, a = 4}, nickname = {

    We are dereferencing a pointer in line 189, but that pointer
    seems to be valid.  So, I don't see any reason why it would
    segfault at that point.

    As you are seeing this problem on multiple Linux
    installations, I'd recommened to use the install_ircg.sh
    script from


    and set CFLAGS in line 19 to "-g".  Also make sure that you
    don't have any old header files/libraries hanging around.

    - Sascha                                     Experience IRCG
      http://schumann.cx/                http://schumann.cx/ircg

PHP Development Mailing List <http://www.php.net/>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to