From:             [EMAIL PROTECTED]
Operating system: linux
PHP version:      4.0.4pl1
PHP Bug Type:     *Configuration Issues
Bug description:  php_flag dosn't work in httpd.conf, but it works in .htaccess files


Maybe I have missunderstud something but I thought that
directives like php_value, php_flag, php_admin_value and 
php_admin_flag may be used in httpd.conf. This doesn't 
seem to be the case with php4.0.4pl1. I have tried it both 
in global, VirtualHost and in a directory section. It 
always cause this error message:
# httpd -t
Syntax error on line 1196 of /etc/httpd/conf/httpd.conf:
Invalid command 'php_flag', perhaps mis-spelled or defined 
by a module not included in the server configuration

I have php4 installed for sure....

Then I tried to put the statment in a .htaccess   
filephp_flag magic_quotes_gpc off
Then it worked

System is apache 1.3.14, php-4.0.4pl1, redhat6.2 and 
./configure  --enable-ftp --with-xml --with-dom 
--enable-trans-sid --with-config-file-path=/etc/httpd 
--with-mysql --with-magic-quotes --with-apxs --with-ttf 
--with-qtdom --with-pgsql --with-gd --with-imap 
--includedir=/usr --with-openssl=/usr --enable-shmop 

Best regards

Edit Bug report at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to