ID: 10219
User Update by: [EMAIL PROTECTED]
Status: Closed
Bug Type: Directory function related
Description: the dir object created using dir() does not contain the last file in the 

Here is the scenario that I have.
I have an nfs mounted a filesystem on SGI Irix machne on to
an redhat 7.1 machine. The error happens within this
file system.

I tried in different directories and got the same result 
and thought it to be a generic problem. It is not.
It works just fine on the local file systems. I have
tried on other remote mounted filesystems that are
mounted from other linux machines and see no problems
there either.
(a diff between nfs2 and nfs3 possibly?)

Previous Comments:

[2001-04-06 21:23:50] [EMAIL PROTECTED]
Can't reproduce with CVS version, try it first and if this still continues reopen the 



[2001-04-06 21:11:12] [EMAIL PROTECTED]

$d = dir("/etc");
echo "Handle: ".$d->handle."<br>n";
echo "Path: ".$d->path."<br>n";
while($entry=$d->read()) {
    echo $entry."<br>n";

It lists all but the last file in the directory.

same result when I tried with opendir() and readdir() combination.


Full Bug description available at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to