ID: 9614
Updated by: sniper
Reported By: [EMAIL PROTECTED]
Old-Status: Feedback
Status: Closed
Bug Type: *Install and Config
Assigned To: 
Comments:

This should be fixed. But if this happens also with soon to 
be released PHP 4.0.5, reopen this bug report.

--Jani


Previous Comments:
---------------------------------------------------------------------------

[2001-03-16 19:53:44] [EMAIL PROTECTED]
Please try with the latest CVS snapshot from http://snaps.php.net/ as Im using libxml 
2.3.4 and it compiles with the latest CVS just fine.

--Jani


---------------------------------------------------------------------------

[2001-03-07 23:11:14] [EMAIL PROTECTED]
When you run configure --with-dom it only checks that you have the libxml library >= 
2.2.7. However the libxml 2.3.x series doesn't work with PHP and causes undefined 
symbols (Either during linking or when Apache loads the module)

I used the following configure options:
./configure  --with-apxs=/usr/apache/bin/apxs --with-zlib --with-regex=system 
--with-readline --with-pdflib --with-mysql=/home/mysql --with-gettext --enable-ftp 
--with-gd=../gd-1.8.4 --with-bz2 --enable-calendar --with-dom 
--with-java=/usr/local/jdk1.3

Here is a simplistic patch that does a poor job of checking that the 2.3.x series is 
not in use.

*** ext/domxml/config.m4.orig   Wed Mar  7 22:56:54 2001
--- ext/domxml/config.m4        Wed Mar  7 23:00:36 2001
***************
*** 4,19 ****
  AC_DEFUN(PHP_DOM_CHECK_VERSION,[
    old_CPPFLAGS=$CPPFLAGS
    CPPFLAGS="-I$DOMXML_DIR/include"
!   AC_MSG_CHECKING(for libxml version)
    AC_EGREP_CPP(yes,[
    #include <libxml/xmlversion.h>
    #if LIBXML_VERSION >= 20207
    yes
    #endif
    ],[
!     AC_MSG_RESULT(>= 2.2.7)
    ],[
!     AC_MSG_ERROR(libxml version 2.2.7 or greater required.)
    ])
    CPPFLAGS=$old_CPPFLAGS
  ])
--- 4,21 ----
  AC_DEFUN(PHP_DOM_CHECK_VERSION,[
    old_CPPFLAGS=$CPPFLAGS
    CPPFLAGS="-I$DOMXML_DIR/include"
!   AC_MSG_CHECKING([for libxml - version >= 2.2.7, < 2.3.x])
    AC_EGREP_CPP(yes,[
    #include <libxml/xmlversion.h>
    #if LIBXML_VERSION >= 20207
+   #if LIBXML_VERSION < 20300
    yes
    #endif
+   #endif
    ],[
!     AC_MSG_RESULT(yes)
    ],[
!     AC_MSG_ERROR([libxml version 2.2.7 or greater (but not 2.3.x series) required.])
    ])
    CPPFLAGS=$old_CPPFLAGS
  ])

---------------------------------------------------------------------------



ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=9614&edit=2


-- 
PHP Development Mailing List <http://www.php.net/>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to