ID: 10196
User Update by: [EMAIL PROTECTED]
Old-Status: Feedback
Status: Open
Bug Type: Pspell related
Description: pspell functions no longer work

Ok, it seems to be a problem with the aspell/pspell freebsd ports collection. They 
aren't building each other correctly or something because when I run your example-c 
program, it says it can't load the aspell module. I'll play around with it some more 
and see if i can make it work. thanks again for your help.

Previous Comments:

[2001-04-09 20:21:05] [EMAIL PROTECTED]

First, make sure you remove the old pspell and aspell installation (I see you upgraded 

Install the new version, go to pspell-.12/examples, build one of their examples, e.g. 
'make example-c', and try to run it as './example-c en', and make sure you can check 
words, get suggestions, etc. If it bombs around here, it is aspell/pspell problem.

Otherwise make sure you have a new snapshot (php404pl1 is too old) and tell me what 
exactly does not work (does apache segfault, or what?)

No, it shouldn't have anything to xslt extension, at least, not that I know of any 
issues. When in doubt, recompile php with pspell support only and test.

Tell me if it worked:)



[2001-04-06 22:54:21] [EMAIL PROTECTED]
I have also downloaded the latest CVS and I get the same problem.


[2001-04-06 22:53:43] [EMAIL PROTECTED]
It wouldn't have anything to do with the sablotron xslt extension i also have compiled 
in would it? I remember reading a post on the dev list that someone had a problem with 
pspell and sablotron and how they wouldn't both work when compiled in together.

here's my configure line if that helps:
./configure --with-apache=../apache_1.3.19 --with-mysql=/usr/local 
--with-png-dir=/usr/local --with-jpeg-dir=/usr/local --with-gd=/usr/local 
--enable-bcmath --enable-trans-sid --disable-pear --disable-posix 
--with-iconv=/usr/local --with-expat-dir=/usr/local --with-sablot=/usr/local 
--enable-inline-optimization --enable-sablot-errors-descriptive --enable-memory-limit 
--disable-short-tags --with-imap --with-zlib=/usr/local --with-pspell=/usr/local 


[2001-04-06 22:11:11] [EMAIL PROTECTED]
I can't reproduce this with latest CVS. Please try the snapshot and if that doesn't 
work, reopen this bug report.



[2001-04-06 15:38:55] [EMAIL PROTECTED]
Here is a bit of sample code:

$pspell_config = pspell_config_create("en");
$pspell_link = pspell_new_config($pspell_config);

$pspell_link does not return any value it seems.


The remainder of the comments for this report are too long.  To view the rest of the 
comments, please view the bug report online.

Full Bug description available at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to