From:             [EMAIL PROTECTED]
Operating system: Linux 2.4.2 i386
PHP version:      4.0 Latest CVS (16/04/2001)
PHP Bug Type:     PHP options/info functions
Bug description:  disable_functions doe not work when set from httpd.conf

I think that disable_functions is not working properly when called from httpd.conf 

php_admin_value disable_functions phpinfo

while it works nice when called from php.ini.
If i run a script with just 


obviously in a dir which is affected by the directive,
the function works ignoring the directive, and gives this results (cut down to just 
the line of interest):

                         local value        master value
disable_functions        phpinfo             system

I have disabled "system" from php.ini, just to didn't work also not setting 
anything in php.ini.
I tried also with safe mode on but no results.
The only functions thatare correctly disabled are the ones set from php.ini.
The same behaviour in php 4.0.6-dev i downloaded today from the CVS...
Am I missing something or this is a bug?
Thanks in advance.

Valerio Morettini

Edit Bug report at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to