ID: 10250
Updated by: kalowsky
Old-Status: Open
Status: Feedback
Bug Type: ODBC related
PHP Version: 4.0.4pl1
Assigned To: 

have you tried this fix with an older version of UnixODBC?

Previous Comments:

[2001-04-09 15:15:59] [EMAIL PROTECTED]
In ext/odbc/php_odbc.c: odbc_sqlconnect(), only Openlink
and Empress can make use of the SQLDriverConnect function.

UnixODBC can use SQLDriverConnect as well, and in the case
of some Easysoft ODBC connections, it *must* be able to use
the SQLDriverConnect format in order to actually connect to
the database.

I have tried changing the 
  #if defined(HAVE_EMPRESS) || defined(HAVE_UNIXODBC)
and everything worked fine, giving full access to the
SQLDriverConnect method of calling odbc_connect and
odbc_pconnect.  If this could be incorporated into a later
release, it would be very useful.

(BTW, this was tested with UnixODBC 2.0.5)


ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to