ID: 9295
Updated by: kalowsky
Old-Status: Feedback
Status: Closed
Bug Type: ODBC related
PHP Version: 4.0.4pl1
Assigned To: 

no user feedback, considered fixed.  if the problem still 
persists, please reopen the bug.

Previous Comments:

[2001-04-01 20:02:21] [EMAIL PROTECTED]
which version of OpenLink are you using?  Supposedly the 
latest OpenLink has been better optimized for use with PHP.  
Please try updating to that (if you haven't already) and 
see if this problem still persists for you...


[2001-02-16 05:47:11] [EMAIL PROTECTED]
Reproducing the problem:
odbc_do($cid, 'Select * from table where datefield=DATE("16/02/2001")');

Warning: SQL error: [unixODBC][OpenLink][ODBC][Driver]Option Value Changed, SQL state 
[? in SQLExecDirect in
/www/data/datetest.php on line 12

Entering the query from the OpenLink odbctest program gives
the desired result.

Using DATE(02,16,2001) gives the same result. 

I've tried with php configured to use both iodbc and
unixODBC. Both produce the same result.

Queries not involving DATE() are working on the same setup. 

My configuration:

I'm running apache 1.3.14


ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to