The upgrade to libtool 1.4 was most likely a big mistake.

Here's what happened on my system where everything worked
just fine before the update:

I have most of the external libraries that the extensions need
in /www/*/lib. And I have these in my configure script: --with-*=/www/*/
where * is the extension. Before that upgrade to libtool 1.4 this
worked nicely. No problems at all. But after update nothing worked.

It all started with having problems with IMAP extension. Reason: I had
a libc-client.a in both /www/imap/lib/ AND /usr/lib. I deleted the one in
/usr/lib and got past that problem. And then the next missing symbol
was in BZ2..I had libbz2.a in /www/bz2/lib and in /usr/lib..

I could have deleted the one in /usr/lib again but that's just fixing the
symptoms and not fixing the real cause for all this.

I then reverted the libtool upgrade patches on my checkout and
now everything works just fine.

So..what should we do about this? Go back to 1.3.5?
Or is there something I have missed? Some setting in libtool
that fixes this?


PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to