ID: 11492
Updated by: sniper
Old-Status: Closed
Status: Feedback
Bug Type: HTTP related
Operating system: 
PHP Version: 4.0.5
Assigned To: 

Could you add a complete but short example script that
doesn't work into this report? Also, does it happen
with ALL browsers? Or only with some specific ones?


Previous Comments:

[2001-06-14 16:24:04] [EMAIL PROTECTED]
I left the domain out and it is still the same issue. It seems to be only in when I 
issue a expiration time into the the cookie. Could the problem be that I use an IP 
address instead of a domain. Could it be that I installed the DSO version of PHP? I am 
so lost on why one version of the setcookie would work and soon as I add one attribute 
it fails. Also sessions are not being envoked as well. I am reading each line of the 
ini file and all seems to be well. Their is DNS attached to the IP but no domain name. 
I also tried to set a javascript cookie with an expiration time and it worked fine. It 
was sceduled to expire in 10 minutes and it worked perfect. Is there some work around 
for this?


[2001-06-14 14:50:03] [EMAIL PROTECTED]
Works for me just fine with NS 4.77 and IE 5.5.
Try leaving the domain out. And if that helps,
then check what the domain in url is when you 
access the if you access it with url:


it wont work.



[2001-06-14 14:05:46] [EMAIL PROTECTED]
I wanted to point out something for the parsing of a setcookie function in PHP on 

If I set a cookie with no attributes like:

setcookie("cookietype", "chocolateChip");

It seems to work fine I can place it before the headers and call it after I select a 
link. Your function list on the quickref page states that setcookie is involved in the 
NS cookie standard format.

i.e. int setcookie("cookie_name", "cookie_value", expire_time, "location", "url", 

When I set a cookie as:

setcookie("cookieType", "oatmealRaisen", time()+45000, "/",

It will not show up or even set. I cleared all of my cookies and accessed the page. My 
script sets the cookie before the header information and then I click a link to a test 
page that calls the cookie and tries to echo the value. No value, check my cookies 
folder and no cookie. Do I need to modify the cookie function in PHP source to work on 
freeBSD or is it missong some special module that parses cookies responsibly.



ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to