ID: 11686
Updated by: sniper
Old-Status: Open
Status: Feedback
Bug Type: Reproducible crash
Operating system: 
PHP Version: 4.0.6
Assigned To: 

I hope you're not using 'apachectl restart'? Use stop/start instead. If this wasn't 
the problem, please generate
a GDB backtrace of the crash. Instructions can be found here:

Previous Comments:

[2001-06-26 02:26:47] [EMAIL PROTECTED]
build php with db2-support, AND java, and ONLY when running it under APACHE (I tried 
several versions, but last time i used:1.3.20).

If i remove db2-support, it works ok, or run php standalone.

this bug exists in db2 7.1 (patchlevel 0,2,3 (latest)).

i have reproduced it under ibmjdk118, ibmjdk1.3, suns jdk1.2.2, suns jdk1.3.

workaround:  don't use db2 in php, do it from java instead.

cd /root
tar xvfz apache_1.3.20.tar.Z 
cd apache_1.3.20
./configure --prefix=/usr/local/apache --enable-module=so
make install

# 1.3
setenv LD_ASSUME_KERNEL 2.2.5

set path = ( /opt/jdk1.3/bin/ $path )
./configure --with-apxs=/usr/local/apache/bin/apxs --without-mysql --enable-sockets 
make install

restart apache)
(try run except.php to load java from apache).
now it works...


add this line to php, (and make rm -rf on the php-directory, because of severe bugs in 
the configure/make process) (only configure from scratch work 100%).
(also add /usr/Ibmdb2/V7.1/lib to LD_LIBRARY_PATH)

(restart apache)
(try run except.php (from netscape) to load java from apache).
now it does not work.
there will be NO response output.


ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to