ID: 11444
Updated by: sniper
Old-Status: Feedback
Status: Closed
Bug Type: Performance problem
Operating system: 
PHP Version: 4.0.5
Assigned To: 

There has been some memory issues solved in PHP 4.0.6.
Please try it out and reopen if this still happens.

Previous Comments:

[2001-06-12 18:51:13] [EMAIL PROTECTED]
So what is the real problem? Does the machine really get 
slow and sluggish? Any errors? Out of memory?
Just one listing of one millisecond situation doesn't

And what were the configure options used? Is PHP compiled
into Apache as DSO or static module?



[2001-06-12 16:40:07] [EMAIL PROTECTED]
I had php-4.0.4pl1 on one of my Solaris machines (SPARC), and was programing on my 
personal workstation (Solaris 8 on SPARC both) on PHP-4.0.6-dev (downloaded 2 days 
after the branch changed from 5 to 6) and PHP worked great with apache.

When I had to pass the programs I had on my workstation, I said, lets update PHP to 
the 4.0.5 version, so there are no problems.

The problems appeared. When I started entering pages on the server where there php 
scripts the load started growing. These are some outputs that I have after executing 
these scripts:

root@ultra31 /space/pruebas # w
  5:30pm  up 75 day(s), 23:32,  2 users,  load average: 6.29, 5.13, 4.71
User     tty           login@  idle   JCPU   PCPU  what
root     pts/0         4:24pm        17:22         bash
postgres pts/3         4:53pm    37                -bash
root@ultra31 /space/pruebas # ps -ef -o pid,ppid,pcpu,pmem,ruser,comm | grep http
18344 18322  0.4  1.9   nobody /usr/local/apache/bin/httpd
18343 18322  0.0  1.1   nobody /usr/local/apache/bin/httpd
18342 18322 18.9  1.9   nobody /usr/local/apache/bin/httpd
18494 18322  0.1  1.5   nobody /usr/local/apache/bin/httpd
18324 18322  9.9  1.9   nobody /usr/local/apache/bin/httpd
 5260 18322  0.1  0.9   nobody /usr/local/apache/bin/httpd
18326 18322  8.0  1.9   nobody /usr/local/apache/bin/httpd
18322     1  0.0  1.6     root /usr/local/apache/bin/httpd
18327 18322  0.4  1.9   nobody /usr/local/apache/bin/httpd
18323 18322  0.1  1.9   nobody /usr/local/apache/bin/httpd
18325 18322 18.6  1.9   nobody /usr/local/apache/bin/httpd
root@ultra31 /space/pruebas #

This also happened with a page that only has the phpinfo() function.

Saludos... :-)



ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to