On Tue, 3 Jul 2001, Stanislav Malyshev wrote:
> Well, if you are around this with @, why not with if(is_array())?
What looks better and is easier to read?:
1.:
if (is_array($ar)) {
foreach ($ar as $element) {
}
}
2.:
@foreach ($ar as $element) {
}
I clearly see some usefulness here. It makes code less cluttered. However,
as foreach is a language construct, I do not think the @ should work on
it. But, making foreach threat NULL variables as empty arrays, would be a
goof thing IMO.
regards,
Derick
--
PHP Development Mailing List <http://www.php.net/>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]