ID: 12360
Updated by: andy
Old Status: Feedback
Status: Analyzed
Bug Type: Sockets related
Operating System: RedHat 6.2
PHP Version: 4.0.6
New Comment:

I have reproduced this error.

When requesting an valid address, but a port that the server
does not listen on, the script hangs.


Previous Comments:

[2001-07-25 09:30:06] [EMAIL PROTECTED]

or at least it doesn't time out until after a very long time....


[2001-07-25 09:29:17] [EMAIL PROTECTED]

it never times out...


[2001-07-25 09:24:26] [EMAIL PROTECTED]

are you saying that is eventually times out (but not a the
number you specified) or are you saying it never times out.


[2001-07-25 07:08:38] [EMAIL PROTECTED]

When I try to connect to a port on a server that isn't reachable or the packets are 
dropped the timeout doesn't work...

This worked when I was using PHP 4.0.4pl1


echo "opening socket... \n";
fsockopen("", 12, $errno, $errstr, 5.0);
echo "$errno\n$errstr\n";
echo "done!\n";


I have also tried this on a Red Hat 7.1 machine and it's just the samee there...

My configure line: './configure' '--with-zlib-dir=/usr/lib' 
'--with-png-dir=/usr/local/lib' '--with-gd=/usr/local' '--with-ttf=/software/freetype' 
'--with-apxs=/software/web/bin/apxs' '--with-mysql=/software/mysql/'


Edit this bug report at

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to