I instantiated new class [ eg.<?  $system = new Java('java.lang.System');  ?>  ].     I got blank response, and that child of Apache died. 

Is this a bug that I should report?  or I'm missing somthing here?   Any expert please give me some suggestions.

For Apache error log,
[Fri Jul 27 17:40:01 2001] [notice] child pid 48040 exit signal Bus error (10)
[Fri Jul 27 17:40:02 2001] [notice] child pid 48041 exit signal Bus error (10)
[Fri Jul 27 17:40:03 2001] [notice] child pid 48042 exit signal Bus error (10)

I use Apache 1.3.20,
PHP Version 4.0.6
./configure --with-apxs=/usr/local/sbin/apxs --with-java=/usr/local/linux-jdk1.3.1

phpinfo() shows Java section fine.
java.class.path   /usr/local/lib/php/php_java.jar:/usr/local/linux-jdk1.3.1/jre/lib/rt.jar
java.home          /usr/local/linux-jdk1.3.1
java.library         libjava.so
java.library.path /usr/local/lib:/usr/compat/linux/lib:/usr/local/linux-jdk1.3.1/jre/lib/i386:/usr/local/linux-jdk1.3.1/jre/lib/i386/hotspot:/usr/local/linux-jdk1.3.1/jre/lib/i386/native_threads

From, php.ini

I tried both Sun Java 1.3.1, and Blackdown 1.2.2.  It gave same error on Apache.  Java itself works fine from shell.

I use FreeBSD 4.3 Stable,  Linux compat mode is on
# kldstat
Id Refs Address    Size     Name
 1    3 0xc0100000 38c5f4   kernel
 2    1 0xc0d47000 3000     daemon_saver.ko  (screen saver)
 3    1 0xc0d4c000 12000    linux.ko

I also set LD_LIBRARY_PATH before I start Apache.
# setenv LD_LIBRARY_PATH /usr/local/lib:/usr/compat/linux/lib:/usr/local/linux-jdk1.3.1/jre/lib/i386:/usr/local/linux-jdk1.3.1/jre/lib/i386/hotspot:/usr/local/linux-jdk1.3.1/jre/lib/i386/native_threads

I run 'ld' .  Seems it finds most dynamic links.
# ld /usr/local/linux-jdk1.3.1/jre/lib/i386/libjava.so
/usr/libexec/elf/ld: warning: cannot find entry symbol _start; not setting start address

Thank you.
slowpork at hotmail.com

Reply via email to