Currently, the rand_functions all have mt_ clones, which use a
in-PHP-implementation (Mersenne-Twister) rather than an external

This is IMHO a bit strange way of chosing between implementation. My
suggestion is to make it only one familiy of functions, the implementation
of which is determined by an ini-entry. (rand = system vs. rand = mt, or
something like that, default: mt).

The functionality is the same (*), and IMO it's a per-system-decision wether
you want to use the mt-algorithms or the system ones. (usually mt, unless
your system has a real good / very special one)

For backwards compatibility, mt_* can be aliased to their normal

(*) as far as you can speak of functionality in this context

PHP Development Mailing List <http://www.php.net/>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to