ID: 12563
User updated by: [EMAIL PROTECTED]
Status: Bogus
Bug Type: Compile Failure
Operating System: RedHat 7.1 / 2.4.7 Kernel
PHP Version: 4.0.6
New Comment:

The Imlib2 guys say it's a PHP bug:

> I reported what I thought to be a PHP bug, they say it's a bug in Imlib2.
> Please have a look.

I don't see how this can be an imlib2 bug. it's a bug in php's autoconf/make
etc. setup - probably related to how they do imlib2 detection and li checking.

they should use imlib2-config

[- 10:07AM ~ -]imlib2-config --version
[- 10:07AM ~ -]imlib2-config --cflags 
-I/usr/local/include -I/usr/X11R6/include
[- 10:07AM ~ -]imlib2-config --libs  
-L/usr/local/lib -lImlib2 -lttf -lm -ldl -lXext -lXext -lX11 -L/usr/X11R6/lib
[- 10:07AM ~ -]imlib2-config --prefix
[- 10:07AM ~ -]imlib2-config --help
Usage: imlib2-config [--prefix[=DIR]] [--exec-prefix[=DIR]] [--version] [--libs]

to figure out cflags and link flags.

this is likely a type.missing character or missing logic statement in their
build procedure. it's not an imlib2 bug - unless your imlib2-config is spewing
out empty results for --libs or --cflags... which it shoudln't.

Previous Comments:

[2001-08-04 00:19:43] [EMAIL PROTECTED]

Not a PHP bug. Report this to the imlib author instead.


[2001-08-04 00:17:05] [EMAIL PROTECTED]

make fails while trying to add Imlib2 support.

./configure --with-xml --with-apxs=/usr/sbin/apxs --with-mysql=/usr --with-pgsql 

I can see the configure script finds my new Imlib2 install:

checking for imlib2 support... yes
checking for imlib_load_image in -lImlib2... yes

anyway, here's the error:

Making all in .
make[1]: Entering directory `/usr/src/php-4.0.6'
/bin/sh /usr/src/php-4.0.6/libtool --silent --mode=link gcc  -I.
-I/usr/src/php-4.0.6/ -I/usr/src/php-4.0.6/main -I/usr/src/php-4.0.6
-I/usr/include/apache -I/usr/src/php-4.0.6/Zend -I/usr/include/mysql
-I/usr/src/php-4.0.6/ext/xml/expat/xmlparse -I/usr/src/php-4.0.6/TSRM
-O2   -o -rpath /usr/src/php-4.0.6/libs -avoid-version
-L/usr/local/pgsql/lib  -R /usr/local/pgsql/lib stub.lo  Zend/
sapi/apache/ main/ regex/
ext/imlib/ ext/mysql/ ext/pcre/
ext/pgsql/ ext/posix/ ext/session/
ext/standard/ ext/xml/ TSRM/ -lpam -ldl
-lpq -lmysqlclient -l -lcrypt -lresolv -lm -ldl -lnsl -lresolv
/usr/bin/ld: cannot find -l--library=crypt
collect2: ld returned 1 exit status
make[1]: *** [] Error 1
make[1]: Leaving directory `/usr/src/php-4.0.6'
make: *** [all-recursive] Error 1

I also tried adding a couple of paths to the --with-imlib switch, /usr/local/lib and 
/usr/local/include.  Both variations produced the same error as above.

I am trying to "add" imlib support.  This is an upgrade on the same version of PHP I'm 
already running, 4.06.  I experienced no missing crypt libraries on the previous 

I don't exactly understand why it's failing on this error:

/usr/bin/ld: cannot find -l--library=crypt

I don't see any kind of crypt files listed in the requirements for Imlib2:

If I leave off the --with-imlib option I get no errors, so I know that's the part 
that's breaking.

When I installed Imlib2 there were no errors, and I see the files:

> locate Imlib2

So I had a look at /etc/  I added /usr/local/lib and ran ldconfig.  This 
didn't help, same errors as above.

A friend pointed out this:

> -lpq -lmysqlclient -l -lcrypt -lresolv -lm -ldl -lnsl -lresolv
>                     ^
>                     |
>             Here's the problem

I have no idea how to fix it, if this is the issue...

I am using

PHP 4.0.6
Apache 1.3.20
MySQL 3.23.40
Postgresql 7.1.2
Imlib2 1.0.1
RedHat 7.1


Edit this bug report at

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to