I downloaded the latest snapshot, this did not work. However it always
bugged me that the file created in apache/src/modules/php4/ was called
libmodphp4.a and not libphp4.a as all the instructions state. I watched the
make install and it *appears* to copy the file libphp4.a and rename it to
libmodphp4.a into the apache directory. Anyway I manually copied the file
libphp4.a into the apache directory and re-ran the configure and make, this
time it worked, the include directories on the gcc compiles were very
different, primarily they pointed to the php directory and this time it

I hope this helps, and thanks for trying.


I still have to

> -----Original Message-----
> From: Bug Database [mailto:[EMAIL PROTECTED]]
> Sent: Tuesday, 7 August 2001 10:57 PM
> Subject: Bug #12616 Updated: Apache make fails, can't find php header
> files
> ID: 12616
> Updated by: andy
> Reported By: [EMAIL PROTECTED]
> Old Status: Open
> Status: Feedback
> Bug Type: Compile Failure
> Operating System: Redhat Linux 7.1
> PHP Version: 4.0.5
> New Comment:
> does this stil happen with latest CVS???
> http://snaps.php.net
> Previous Comments:
> --------------------------------------------------------------
> ----------
> [2001-08-07 06:52:48] [EMAIL PROTECTED]
> apache_1.3.19# ./configure --prefix=/usr/local/apache
> php-4.05# ./configure --with-mysql --enable-track-vars
> --with-apache=../apache_1.3.19
> php-4.05# make -ok, make install - ok
> apache_1.3.19# ./configure --prefix=/usr/local/apache
> --activate-module=src/modules/php4/libmodphp4.a - ok
> apache_1.3.19# make -errors see below
> gcc -c  -I../../os/unix -I../../include   -DLINUX=22
> -DUSE_HSREGEX -DUSE_EXPAT -I../../lib/expat-lite
> -DNO_DL_NEEDED `../../apaci`  mod_ph4.c
> mod_php4.c:28:18: zend.h: No such file or directory
> mod_php4.c:29:17: php.h: No such file or directory
> mod_php4.c:30:27: php_variables.h: No such file or directory
> mod_php4.c:47:21: php_ini.h: No such file or directory
> mod_php4.c:48:25: php_globals.h: No such file or directory
> mod_php4.c:49:18: SAPI.h: No such file or directory
> mod_php4.c:50:22: php_main.h: No such file or directory
> mod_php4.c:52:26: zend_compile.h: No such file or directory
> mod_php4.c:53:26: zend_execute.h: No such file or directory
> mod_php4.c:54:28: zend_highlight.h: No such file or directory
> mod_php4.c:55:25: zend_indent.h: No such file or directory
> mod_php4.c:57:39: ext/standard/php_standard.h: No such file
> or directory
> make[4]: *** [mod_php4.o] Error 1
> etc.
> I tried to change the gcc command to include the
> /usr/local/include directory in which the missing files are
> located (well they are under that directory) however it
> caused another bunch of dependency problems.
> I have had this problem with Redhat7.0 all versions of php
> and apache I could get my hands on.
> I can't find any reports of this problem, and don't see what
> I may be doing wrong.
> --------------------------------------------------------------
> ----------
> ATTENTION! Do NOT reply to this email!
> To reply, use the web interface found at
> http://bugs.php.net/?id=12616&edit=2

PHP Development Mailing List <http://www.php.net/>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to