ID: 11058
User updated by: [EMAIL PROTECTED]
Status: Open
Bug Type: HTTP related
Operating System: OpenBSD 2.6
PHP Version: 4.0.6
New Comment:

Still not resolved.

I commented out the line:


from my main/php_config.h file, did a make, then a make install. Recompiled Apache, 
stopped and started the server, and still have the same errors.

I also tried changing the value to 0, and did the same to #define LIBRESOLV 1 to see 
if that was the problem (for some reason there are 2 identical lines with LIBRESOLV in 
my php_config.h file). Nothing.

Any ideas? This was working perfectly before upgrading to PHP4, and I haven't touched 
the box except to upgrade Apache and install OpenSSL.

Previous Comments:

[2001-08-07 12:56:13] [EMAIL PROTECTED]

Still having the same issue with 4.0.6 now. I'll try and recompile without the 
GETADDRINFO line and see what happens.


[2001-08-03 22:53:11] [EMAIL PROTECTED]

What's the status for this?? 


[2001-07-22 04:45:41] [EMAIL PROTECTED]

Could you try to comment out the line
in main/php_config.h and rebuild without doing configure?
Does it work then? There are some broken getaddrinfo()
implementations out there, but I would be surprised if
there were problems with OpenBSD in general. Might be
something wrong with your resolver library.

OTH, you also have a problem with fsockopen() and that
uses the old gethostbyname() I think, so it seems to be resolving in general.


[2001-07-21 21:47:35] [EMAIL PROTECTED]

Please check that your nameserver is running and setup
correctly.  Check the same with your internet server.


[2001-05-23 11:58:00] [EMAIL PROTECTED]

I've seen this issue posted here a few times, and I think my problem is similar to Bug 
id #7880.

fopen(), fsockopen(), and file() will not work with URL or IP address parameters. 
include() has the same issue. I believe it has something to do with getaddrinfo.

Before upgrading to PHP4, I was running 3.0.16 and all of these functions were working 
perfectly with URL parameters. 

My configure script looks like this:

./configure  --with-apache=/usr/temp/apache_1.3.19 --with-mysql=/usr/local 
--enable-track-vars --with-xml --with-openssl=/usr/local/ssl

My php.ini DOES contain the line "allow_url_fopen = On"

The fopen() script looks like this:

        $fd = fopen( "";, "r" );
        if( !$fd )
                echo "Cannot open URL";
        } else {
                while ( !feof( $fd ) ) {
                        $buffer = fgets( $fd, 4096 );
                        echo $buffer;
                fclose ( $fd );

and produces this output:

Warning: php_network_getaddresses: getaddrinfo failed: name or service is not known in 
/var/www/ on line 24

Warning: fopen("","r";) - Bad file descriptor in 
/var/www/ on line 24
Cannot open URL 

and yes, I can resolve to Using the IP address in place of 
the hostname produces the same output.

If I use the fsockopen() function with this script:

        fsockopen("";, 80, &$errno, &$errstr, 30);
        if(!$fp) {
                echo "Error: $errstr ($errno)<br>\n";
        } else {
                fputs($fp,"GET / HTTP/1.0\n\n");
                while(!feof($fp)) {
                        echo fgets($fp,128);

I get this output:

Error: (0)


Edit this bug report at

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to