ID: 12990
Updated by: lyric
Status: Feedback
Bug Type: Program Execution
Operating System: Redhat 7.1
PHP Version: 4.0.6
New Comment:

User replied:
The problem is that I used exec() before the update and it worked fine. I have another 
script that does the same thing that script doesnt work anymore either.

No other employee at my work have changed the file so the update is the only thing I 
can think of to blame.

Plenty of things changed, including a lot of stuff with Redhat 7.0 -> 7.1.  Did you 
recompile PHP after the upgrade?

Again, what does $cmd actually return?  Also, try :
   $line = system($cmd,$retvar);
   $msg = "system($cmd) --> $retvar, $line";
and tell me what it says

Previous Comments:

[2001-08-28 04:51:04] [EMAIL PROTECTED]

What does $cmd actually return?  system() returns the last line of output from the 
command, which will evaluate to false for things like "0" or "".  Try using exec() and 
printing the output from there if you are unsure. 


[2001-08-28 02:42:30] [EMAIL PROTECTED]


Then we made a upgrade från Redhat 7.0 and PHP 404 this syntax stopped to work. It 
keep tellning me that the command failed. 

        $Msg.="The command was successful.";
        $Msg.="Nope it didnt worked.";


Edit this bug report at

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to