ID: 13076
User updated by: [EMAIL PROTECTED]
Status: Open
Bug Type: GD related
Operating System: FreeeBSD 4.3 and Mandrake 7.2
PHP Version: 4.0.6
New Comment:

In fact, I use the ports from FreeBSD. The looks like this :

LIB_DEPENDS+=   gd.2:${PORTSDIR}/graphics/gd
LIB_DEPENDS+=   freetype.7:${PORTSDIR}/print/freetype2
LIB_DEPENDS+=   png.4:${PORTSDIR}/graphics/png
LIB_DEPENDS+=   jpeg.9:${PORTSDIR}/graphics/jpeg
                --with-freetype-dir=${PREFIX} \
                --with-jpeg-dir=${PREFIX} \

During the configuration phase, I can see the following message :

"Checking whether to include freetype text support in GD... no" (or something like 
this :o) )

and few lines bellow :

"Checking for Freetype(2)... found"

phpinfo() give me the following :

GD Support enabled 
GD Version 1.6.2 or higher 
FreeType Support enabled 
FreeType Linkage with freetype 
JPG Support enabled 
PNG Support enabled 
WBMP Support enabled 

And of course the ImageTTFText doesn't work telling me that libgd is compiled without 
the support for freetype.

Not true cause I can launch the exe example gdtestft.

So I've tried to add the following in the but I still have the "Checking 
whether to include freetype text support in GD... no" :




The problem is on a FreeBSD 4.3, with PHP 4.0.6, GD 1.8.4 and Freetype 2.0.4 but I've 
noticed the same problem on other configuration like a Mandrake 7.2, running PHP 


Previous Comments:

[2001-08-31 06:44:16] [EMAIL PROTECTED]

Can you post your configure-line of PHP and of GD?


[2001-08-31 06:21:24] [EMAIL PROTECTED]

I've tried on two systems to build PHP with GD and Freetype 2.

It doesn't work. PHP always report in the configuration phase that Freetype 2 support 
is not enabled in GD. But it is enabled cause I can launch the gdtestft !!!


Edit this bug report at

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to