Hi,

> After typing the 16 characters in the htmlspecialchars() function thousands 
> of times...

When you have to type it 16 times, then you did something wrong.
Consider this:

foreach($_GLOBAL as $key => $val)
  $$key = htmlspecialchars($val);

Replace $_GLOBAL by $_COOKIES, $_GET, .. OR you could just group
together variables:

  <input type="text" name="form[name]" ..>

and go through $form in your script.

> I was wondering if it would be feasible to create an alias for this 
> function, say hsc() or something short.

> [..]

> It is no big deal, but for a function that is used ALL THE TIME, it would 
> be nice.

why do something in C, when it can be done in PHP so nicely:

function hsc(&$var) {
  $var = htmlspecialchars($var);
}

Alias are terrible. The decrease readability of your code. Actually
doing hsc() in PHP is compareable silly.

Kind Regards,
  Daniel Lorch
-- 
@echo "Hello, World";



-- 
PHP Development Mailing List <http://www.php.net/>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to