At 02:43 AM 7/30/2002 -0400, Andrei Zmievski wrote:
>On Tue, 30 Jul 2002, Andi Gutmans wrote:
> > Hey,
> >
> > Can't you share the patch before you just go ahead and just commit it? I
> > still have the same issue I used to have.
>
>Hey, the patch has been available for a long while now. :-)
>
> > I think using the cast operators for the types is pretty ugly. The code
> > looks something like:
> > $foo is (int)
> > I we should only support classes and not support basic types? We have the
> > non-OOP function for those. This is really an OOP operator.
>
>Don't you think we should have a unified way of testing for variable's
>type/class? I understand that we don't have type unification yet, but
>having a separate function for each basic type is kind of ugly too.

I'd prefer "is" to be an OOP only construct. i.e. for anything other than 
an object it'd return false.
Just some food for though before we finalize this. This operator will be a 
reserved word. Are we sure we want "is" to be a reserved word? It might be 
used quite a bit.


> > BTW: I think it's a good idea to not declare is_type_expr in the parser 
> but
> > to use catch_or_import_class_entry and change its name to something which
> > fits both. I don't like declaring the same rules more than once if I can
> > help it. This rule will probably also be useful for future things.
>
>Yeah, I think it's a good idea too. Should we call it "class_entry_ref"
>or something like that?

OK by me. I can't think of a very sexy name myself.

Andi


-- 
PHP Development Mailing List <http://www.php.net/>
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to