This worked fine! Thanks for this input.

- Ananth.

>>> "Edin Kadribasic" <[EMAIL PROTECTED]> 10/29/02 03:18PM >>>
Adding folder is not enough. You need to add the files within the
folder as well.

Hope this helps,
----- Original Message -----
From: "Ananth Kesari" <[EMAIL PROTECTED]>
Sent: Tuesday, October 29, 2002 10:32 AM
Subject: Re: [PHP-CVS] Some NetWare files are not getting committed.

Thanks for the inputs. Still I do not get NetWare folder.

I did the following:

In the .cvsrc file:
  cvs -z3
  update -d
  checkout -P
  diff -u

I did:
  cvs add -m "NetWare related files." netware

The netware folder had all the files within it with a sub-directory
also by name sys. I got a list of all these files and was told that
these were added. Then I went into the sys sub-directory and added
it also with the files within it. It told me that those files were
added too.

Then I did:
  cvs commit -m "NetWare related files." netware

It said:
  Examining netware
  Examining netware\sys

Then it came out without doing anything.

Then when I did: "cvs co -r PHP_4_2_0 php4", I still DON'T get the
netware folder.

I tried all the above with the following entries in the .cvsrc file:
  cvs -z3
  update -d
  diff -u

Still the same result. I do not get netware folder when I do a

For your information, NetWare and sys folders were not empty when I
first did the add and commit last Friday and also yesterday.

Can you let me know what to do now?


>>> Melvyn Sopacua <[EMAIL PROTECTED]> 10/28/02 08:55PM >>>
At 15:49 28-10-2002, Ananth Kesari wrote:

>But I need to add a folder by name, "netware" with
>some NetWare specific files within it. These are NOT
>getting committed. If I "add" it gets added. I once
>committed on Thursday. Now, if I commit, it verifies
>and does nothing indicating that it is already committed.
>But if I check-out the 4.2 project, I do not get
>the "netware" folder.
>Can anyone tell me what's wrong? I am a beginner
>to this CVS process and so I may be missing something
>even simple or obvious.

Since you probably have update -d -P in your ~/.cvsrc like
you should, the directory won't show up, untill you commit
files in them.

Remove the -P option from your ~/.cvsrc directory temporarily
to get the netware directory back.

-P means prune, which deletes empty dirs
-d means create new directory

that's cause the conflict.


With kind regards,

Melvyn Sopacua
<?php include("not_reflecting_employers_views.txt"); ?>

PHP CVS Mailing List (
To unsubscribe, visit: 

PHP CVS Mailing List (
To unsubscribe, visit: 

PHP CVS Mailing List (
To unsubscribe, visit: 

PHP Development Mailing List <>
To unsubscribe, visit:

Reply via email to