As far as I can tell, the problem is that currently the so called
LinkCollectionInterface describes two methods which, as per docblocks,
"return a collection".
So we have something called collection which in turn returns collections;
Calling it "Catalog" doesn't cut it, in my opinion, because the ambiguity
remains: "catalog" can easily be interpreted as a synonym of "collection".
"Collector" doesn't cut it either, because I would expect it to provide
some kind of command (i.e. "collect()"), not queries.
Now I'm not big on naming, but something like LinksProvider or
LinkCollectionProvider would probably communicate the intent more
Then again, the presence of EvolevableLinkCollectionInterface makes it even
more unclear whether or not we're talking about something that is-a
collection or has-a collection.
I understand the need for this interfaces, but the current naming is
I don't know better, I'll let you folks brainstorm on this.
You received this message because you are subscribed to the Google Groups "PHP
Framework Interoperability Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email
To post to this group, send email to firstname.lastname@example.org.
To view this discussion on the web visit
For more options, visit https://groups.google.com/d/optout.