I will definitely agree that there are a few inconsistencies in the 
function naming... more than likely due to the many many contributors, 
and a lack of strict naming conventions.

Never quite understood (for example) why half of the string based 
functions are named str* and the other half str_*, eg

str_replace, str_pad, str_repeat, str_word_count, etc as opposed to
strlen, strrev, strstr, strchr, strpos, etc

But all it really means is another trip to the manual if my first 
"guess" for the function name doesn't work.


It'd be nice if things could have been standardised in PHP5, with 
aliases to the functions with older (deprecated?) names, but I guess 
it's WAAAY too late for that!!


Justin


--
PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to