Just a quick question. Does it really matter how long your code is or how many variables you use? For instance you can enter the following...
$imgBkgrnd = array("1"=> "bkgrnd-default.gif", "2" => "bkgrnd-positive.gif", "3" => "bkgrnd-negative.gif"); $imgNeeded = table['field']; $imgName = $imgBkgrnd[$imgNeeded]; or, you can code the same thing as... $imgBkgrnd = array("1"=> "bkgrnd-default.gif", "2" => "bkgrnd-positive.gif", "3" => "bkgrnd-negative.gif"); $imgName = $imgBkgrnd[$table['field']]; The first example uses one more variable and a longer code block but is easier to read and debug. The second example uses one less variable and a shorter code block but is harder to debug later. Should I be striving for the shortest most compact code utilizing the fewest possible variables. Or, can I code in a style which is easier to read and debug? -- Robb Kerr Digital IGUANA Helping Digital Artists Achieve their Dreams ---------------------------------------------------- http://www.digitaliguana.com http://www.cancerreallysucks.org -- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php