On Mon, 2005-11-21 at 09:42, Chris Boget wrote:
> >> and I feel it would be more elegant to be able to do something like:
> >> $var ="first part of string {(($a==$b)?$c:$d)} rest of string";
> > $templateStr = 'first part of string %s rest of string';
> > $outputStr   = sprintf($templateStr, (($a==$b)?$c:$d));
> 
> That is so totally slick!  I'm definitely going to have to remember this
> neat little trick! :)

That's like using a bulldozer to tidy your living room. Why not use the
following even more readable style (and more efficient)?

$outputStr =
    'first part of string  '
   .($a == $b ? $c : $d)
   .' rest of string';

Cheers,
Rob.
-- 
.------------------------------------------------------------.
| InterJinn Application Framework - http://www.interjinn.com |
:------------------------------------------------------------:
| An application and templating framework for PHP. Boasting  |
| a powerful, scalable system for accessing system services  |
| such as forms, properties, sessions, and caches. InterJinn |
| also provides an extremely flexible architecture for       |
| creating re-usable components quickly and easily.          |
`------------------------------------------------------------'

-- 
PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to