Thankyou,

I took "application/x-javascript" directly from the apache setup for my domain so this should be correct.


However I've just deactivated gzip (zlib.output_compression OFF in php.ini) and that stopped the problem. I've given you a simplified version of the script that has the exact same problem (the original one gets the mime type automaticaly and has the same problem with any files that are gziped (css, html, javascript etc... but not images.).

So the problem seems to have someting to do with this line :

header('Content-Length: '.filesize('test.js'));
and with gzip ...

I would like to be able to activate gzip again but I need to work out why I'm getting this bug first.

Apache isn't installed with mod_deflate, should I look into doing this instead of turning zlib.output_compression on again ?

Is there maybe a bug with PHP 5.2.9 that's causing this problem?

Thankyou :)

haliphax a écrit :
On Thu, Mar 5, 2009 at 10:27 AM, Jsbeginner <jsbegin...@monarobase.net> wrote:
Hello, Just to say that I've got a bit further in my search :

<?php
header('Content-Type: application/x-javascript');
//header('Content-Length: '.filesize('test.js'));
readfile('test.js');
?>

(Content-Length line removed) Has no lag...

My guess is there is a problem with gzip or something that corrupts the
content-length.

So I'm still not sure if this is a PHP problem or an apache problem but any
help would be great :)

Thankyou


Jsbeginner a écrit :
Hello,

I don't know for sure is this problem is only related to PHP so I hope
I've posted in the right list.

My problem is that with certain headers my script takes about 5 seconds
before sending the page, no matter how small the file I try to load...
My server :
Centos
Apache 2.2
PHP 5.2.9

Here's my code :

<?php
header('Content-Type: application/x-javascript');
header('Content-Length: '.filesize('test.js'));
readfile('test.js');
?>

test.js is only a few lines long, and if I remove the header content type
the file loads instantaniously do it's not a problem with readfile.
I thought about zlib gzip taking maybe a long time to load but I've
changed the compression level from 6 to 1 and the file still has a the same
lag.

My server responds very fast for eveything else except this script. Do you
have an idea what might be causing this lag ?

Thanks in advance :)

Well, have you tried using Content-Type: "text/javascript" as
suggested? Is "application/x-javascript" absolutely necessary for
whatever application is reading your script's output? As it has
already been mentioned, Apache may be looking for your content type in
some sort of lookup table, not finding it, and taking its sweet time
returning control back to PHP while it grabs at straws to match.



Reply via email to